$re = '/([^\n]+)/m';
$str = '01.текст
90. текст';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;