use strict;
my $str = '01.текст
90. текст';
my $regex = qr/([^\n]+)/mp;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";