import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[INFO\\](?:(?: +(?:\\||\\+-|\\\\-))+)? +\\(?(.*?)\\)?$";
final String string = "[INFO] com.demo:communication:jar:3.5.0-SNAPSHOT\n"
+ "[INFO] +- com.cellwize.optserver:optserver-admin:jar:3.5.0-SNAPSHOT:compile\n"
+ "[INFO] | +- org.apache.logging.log4j:log4j-api:jar:2.7:compile\n"
+ "[INFO] | +- org.apache.logging.log4j:log4j-core:jar:2.7:compile\n"
+ "[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)\n"
+ "[INFO] | +- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.7:compile\n"
+ "[INFO] | | +- org.slf4j:slf4j-api:jar:1.7.21:compile\n"
+ "[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}