# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[INFO\](?:(?: +(?:\||\+-|\\-))+)? +\(?(.*?)\)?$"
test_str = ("[INFO] com.demo:communication:jar:3.5.0-SNAPSHOT\n"
"[INFO] +- com.cellwize.optserver:optserver-admin:jar:3.5.0-SNAPSHOT:compile\n"
"[INFO] | +- org.apache.logging.log4j:log4j-api:jar:2.7:compile\n"
"[INFO] | +- org.apache.logging.log4j:log4j-core:jar:2.7:compile\n"
"[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)\n"
"[INFO] | +- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.7:compile\n"
"[INFO] | | +- org.slf4j:slf4j-api:jar:1.7.21:compile\n"
"[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.