re = /^\[INFO\](?:(?: +(?:\||\+-|\\-))+)? +\(?(.*?)\)?$/m
str = '[INFO] com.demo:communication:jar:3.5.0-SNAPSHOT
[INFO] +- com.cellwize.optserver:optserver-admin:jar:3.5.0-SNAPSHOT:compile
[INFO] | +- org.apache.logging.log4j:log4j-api:jar:2.7:compile
[INFO] | +- org.apache.logging.log4j:log4j-core:jar:2.7:compile
[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)
[INFO] | +- org.apache.logging.log4j:log4j-slf4j-impl:jar:2.7:compile
[INFO] | | +- org.slf4j:slf4j-api:jar:1.7.21:compile
[INFO] | | \\- (org.apache.logging.log4j:log4j-api:jar:2.7:compile - omitted for duplicate)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result