package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,2}\/\d{1,2}\/\d{1,4}\s+R[$]((?:\d+\.)?\d+\,\d+)`)
var str = ` 18/01/2021 R$37.187,30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}