package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)(?:END|\A).*?(?:START|\z)(*SKIP)(*F)|\R`)
var str = `some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify`
var substitution = "\n\t"
fmt.Println(re.ReplaceAllString(str, substitution))
}