use strict;
my $str = 'some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify';
my $regex = qr/(?s)(?:END|\A).*?(?:START|\z)(*SKIP)(*F)|\R/mp;
my $subst = '\\n\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";