// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?s)(?:END|\A).*?(?:START|\z)(*SKIP)(*F)|\R").unwrap();
let string = "some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify";
let substitution = "\\n\\t";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}