package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+$`)
var str = `1123-xxx-abcd-45-tsvt-35-pwrst-99-xql`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}