$re = '/^(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+$/m';
$str = '1123-xxx-abcd-45-tsvt-35-pwrst-99-xql';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);