re = /^(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+(\d+)[^\d]+$/m
str = '1123-xxx-abcd-45-tsvt-35-pwrst-99-xql'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end