#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a class="keyword" href=".+?">(.+?)<\/a>"
Local $sString = "<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> では以下の様な<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> が提供されています。"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")