package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a class="keyword" href=".+?">(.+?)<\/a>`)
var str = `<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> では以下の様な<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> が提供されています。`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}