$re = '/<a class="keyword" href=".+?">(.+?)<\/a>/m';
$str = '<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> では以下の様な<a class="keyword" href="http://d.hatena.ne.jp/keyword/API">API</a> が提供されています。';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);