using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*[a-z]{2}|.*[0-9]{2})[a-z0-9]{3,5}$";
string input = @"a1
a1b2
a1b2c3
a1b2c3d4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}