const regex = /^(?!.*[a-z]{2}|.*[0-9]{2})[a-z0-9]{3,5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*[a-z]{2}|.*[0-9]{2})[a-z0-9]{3,5}$', 'gm')
const str = `a1
a1b2
a1b2c3
a1b2c3d4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}