$re = '/^(?!.*[a-z]{2}|.*[0-9]{2})[a-z0-9]{3,5}$/m';
$str = 'a1
a1b2
a1b2c3
a1b2c3d4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);