re = /<([a-z]\w*)\b[^>]*>.*/m
str = '<b>
<i>
<9avc>
<div>
<span> <i> something </i> </span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end