import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(.*)([\\/](\\w+))(\\.(jpg|png|gif|jpeg))";
        final String string = "https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg\n"
	 + "https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.png\n"
	 + "https://res.cloudinary.com/gametecgroup/image/upload/v1541159458/assets/img/bannerPrincipal.png\n"
	 + "https://res.cloudinary.com/gametecgroup/image/upload/images_qqz2i9.jpg\n"
	 + "https://res.cloudinary.com/gametecgroup/image/upload/3246234_640px_qv2lzl.jpg";
        final String subst = ">>>> $3 <<<<< ";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceAll(subst);
        
        System.out.println("Substitution result: " + result);
    }
}