import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<col1>[^\\\"]*?)\\\",(\\\"(?<col2>[^\\\"]*?)\\\",)?(\\\"(?<col3>[^\\\"]*?)\\\",)?(\\\"(?<col4>[^\\\"]*?)\\\")?";
final String string = "\"r1col1\",\"r1col2\"\n"
+ "\"r1col1\",\"r1col2\",\"r1col3\"\n"
+ "\"r2col1\",\"r2col2\",\"r2col3\",\"r2col4\"\n"
+ "\"r2col1\",\"r2col2\",\"r2col3\",\"r2col4\",\"r2col5\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}