$re = '/(?<col1>[^\"]*?)\",(\"(?<col2>[^\"]*?)\",)?(\"(?<col3>[^\"]*?)\",)?(\"(?<col4>[^\"]*?)\")?/m';
$str = '"r1col1","r1col2"
"r1col1","r1col2","r1col3"
"r2col1","r2col2","r2col3","r2col4"
"r2col1","r2col2","r2col3","r2col4","r2col5"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);