const regex = /(?<col1>[^\"]*?)\",(\"(?<col2>[^\"]*?)\",)?(\"(?<col3>[^\"]*?)\",)?(\"(?<col4>[^\"]*?)\")?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<col1>[^\\"]*?)\\",(\\"(?<col2>[^\\"]*?)\\",)?(\\"(?<col3>[^\\"]*?)\\",)?(\\"(?<col4>[^\\"]*?)\\")?', 'gm')
const str = `"r1col1","r1col2"
"r1col1","r1col2","r1col3"
"r2col1","r2col2","r2col3","r2col4"
"r2col1","r2col2","r2col3","r2col4","r2col5"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}