#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[sS]ee, e\.g\.,.*(\(D\.C\. Cir\.)?.*(\(11th Cir\.)?.*(\(10th Cir\.)?.*(\(9th Cir\.)?.*(\(8th Cir\.)?.*(\(7th Cir\.)?.*(\(6th Cir\.)?.*(\(5th Cir\.)?.*(\(4th Cir\.)?.*(\(3d Cir\.)?.*(\(2d Cir\.)?.*(\(1st Cir\.)?.*\."
Local $sString = "See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017)." & @CRLF & _
"See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017)." & @CRLF & _
"See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017)." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017)." & @CRLF & _
"See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017)." & @CRLF & _
"See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")