re = /[sS]ee, e\.g\.,.*(\(D\.C\. Cir\.)?.*(\(11th Cir\.)?.*(\(10th Cir\.)?.*(\(9th Cir\.)?.*(\(8th Cir\.)?.*(\(7th Cir\.)?.*(\(6th Cir\.)?.*(\(5th Cir\.)?.*(\(4th Cir\.)?.*(\(3d Cir\.)?.*(\(2d Cir\.)?.*(\(1st Cir\.)?.*\./m
str = 'See, e.g., Smith v. U.S. (1st Cir. 2012); U.S. v. Sara (5th Cir. 2017).
See, e.g., Jefferson v. U.S. (10th Cir. 2012); U.S. v. Coolidge (D.C. Cir. 2017).
See, e.g., Lincoln v. Jones (3d Cir. 2012); U.S. v. Roosevelt (9th Cir. 2017).
See, e.g., Smith v. U.S. (5th Cir. 2012); U.S. v. Sara (1st Cir. 2017).
See, e.g., Jefferson v. U.S. (D.C. Cir. 2012); U.S. v. Coolidge (10th Cir. 2017).
See, e.g., Lincoln v. Jones (9th Cir. 2012); U.S. v. Roosevelt (3d Cir. 2017).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end