const regex = /my(?:\s+\w+){0,2}\s+words/im;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('my(?:\\s+\\w+){0,2}\\s+words', 'im')
const str = `I'm searching for my funny words inside this text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}