$re = '/my(?:\s+\w+){0,2}\s+words/im';
$str = 'I\'m searching for my funny words inside this text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);