re = /my(?:\s+\w+){0,2}\s+words/im
str = 'I\'m searching for my funny words inside this text'
# Print the match result
str.match(re) do |match|
puts match.to_s
end