use strict;
my $str = '#26,968 in Office Products (See top 100)
#13,452 in Industrial & Scientific > Abrasive & Finishing Products
#99,999 in baby
#888 in office supplies';
my $regex = qr/.*(#\d*\,?\d+)\s.*in\s(.*?)\s*(?=[(>]|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}