$re = '/.*(#\d*\,?\d+)\s.*in\s(.*?)\s*(?=[(>]|$)/m';
$str = '#26,968 in Office Products (See top 100)
#13,452 in Industrial & Scientific > Abrasive & Finishing Products
#99,999 in baby
#888 in office supplies';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);