re = /.*(#\d*\,?\d+)\s.*in\s(.*?)\s*(?=[(>]|$)/m
str = '#26,968 in Office Products (See top 100)
#13,452 in Industrial & Scientific > Abrasive & Finishing Products
#99,999 in baby
#888 in office supplies'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end