const regex = /((.+).*),(?!.*(?=\1)((?=(..+)(\4+$))\5)*(?!\2)).*(?=\1)\K(?3)*\2$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((.+).*),(?!.*(?=\\1)((?=(..+)(\\4+$))\\5)*(?!\\2)).*(?=\\1)\\K(?3)*\\2$', 'mg')
const str = `111,11111
11111,11111111111
111111111,11111111111
111111111,1111111111111111111
11111111111111111111111111111111,1111111111111111111111111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}