re = /((.+).*),(?!.*(?=\1)((?=(..+)(\4+$))\5)*(?!\2)).*(?=\1)\K(?3)*\2$/m
str = '111,11111
11111,11111111111
111111111,11111111111
111111111,1111111111111111111
11111111111111111111111111111111,1111111111111111111111111111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end