$re = '/((.+).*),(?!.*(?=\1)((?=(..+)(\4+$))\5)*(?!\2)).*(?=\1)\K(?3)*\2$/m';
$str = '111,11111
11111,11111111111
111111111,11111111111
111111111,1111111111111111111
11111111111111111111111111111111,1111111111111111111111111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);