#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Z]*(?: +[A-Z]+){4,}"
Local $sString = "This reges should capture repeated words WRITTEN IN UPPERCASE ONE AFTER THE other." & @CRLF & _
"" & @CRLF & _
" \*literal asterisks\*" & @CRLF & _
"" & @CRLF & _
"Markdown provides backslash escapes for the following characters:" & @CRLF & _
"" & @CRLF & _
" \ backslash" & @CRLF & _
" ` backtick" & @CRLF & _
" * asterisk" & @CRLF & _
" _ underscore" & @CRLF & _
" {} curly braces" & @CRLF & _
" [] square brackets" & @CRLF & _
" () parentheses" & @CRLF & _
" # hash mark" & @CRLF & _
" + plus sign" & @CRLF & _
" - minus sign (hyphen)" & @CRLF & _
" . dot" & @CRLF & _
" ! exclamation mark" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")