$re = '`[A-Z]*(?: +[A-Z]+){4,}`';
$str = 'This reges should capture repeated words WRITTEN IN UPPERCASE ONE AFTER THE other.
\\*literal asterisks\\*
Markdown provides backslash escapes for the following characters:
\\ backslash
` backtick
* asterisk
_ underscore
{} curly braces
[] square brackets
() parentheses
# hash mark
+ plus sign
- minus sign (hyphen)
. dot
! exclamation mark
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);