import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]*(?: +[A-Z]+){4,}";
final String string = "This reges should capture repeated words WRITTEN IN UPPERCASE ONE AFTER THE other.\n\n"
+ " \\*literal asterisks\\*\n\n"
+ "Markdown provides backslash escapes for the following characters:\n\n"
+ " \\ backslash\n"
+ " ` backtick\n"
+ " * asterisk\n"
+ " _ underscore\n"
+ " {} curly braces\n"
+ " [] square brackets\n"
+ " () parentheses\n"
+ " # hash mark\n"
+ " + plus sign\n"
+ " - minus sign (hyphen)\n"
+ " . dot\n"
+ " ! exclamation mark\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}