# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(the|of) | (the|of)$| (of|the)(?= )//img;t' <<< "the lord of the ring and then often"