$re = '/^(the|of) | (the|of)$| (of|the)(?= )/im';
$str = 'the lord of the ring and then often';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;