use strict;
my $str = 'the lord of the ring and then often';
my $regex = qr/^(the|of) | (the|of)$| (of|the)(?= )/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";