using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z !""#$%&'()*+,-.\/:;<=>?@\[\\\]^_`{|}~]{8,255}";
string input = @"Abcdefg !""#$%&'()*+,-./:;<=>?@[\]^_`{|}~1!hi";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}