import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])[0-9a-zA-Z !\"#$%&'()*+,-.\\/:;<=>?@\\[\\\\\\]^_`\\{|\\}~]{8,255}";
final String string = "Abcdefg !\"#$%&'()*+,-./:;<=>?@[\\]^_`{|}~1!hi";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}