using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^\d+(\D+)\d+(?:\1\d+)*$)";
string input = @"1, 2, 3, 4
1 2 3 4
1|2|3|4
1¯\\_(ツ)_/¯2¯\\_(ツ)_/¯3¯\\_(ツ)_/¯4
1 2 3,4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}