re = /(?=^\d+(\D+)\d+(?:\1\d+)*$)/m
str = '1, 2, 3, 4
1 2 3 4
1|2|3|4
1¯\\\\_(ツ)_/¯2¯\\\\_(ツ)_/¯3¯\\\\_(ツ)_/¯4
1 2 3,4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end