$re = '/(?=^\d+(\D+)\d+(?:\1\d+)*$)/m';
$str = '1, 2, 3, 4
1 2 3 4
1|2|3|4
1¯\\\\_(ツ)_/¯2¯\\\\_(ツ)_/¯3¯\\\\_(ツ)_/¯4
1 2 3,4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);