#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!Type\=\w+).+"
Local $sString = "2/01/2018 09:56:03 AM" & @CRLF & _
"LogName=Security" & @CRLF & _
"SourceName=Microsoft Windows security auditing." & @CRLF & _
"EventCode=4624" & @CRLF & _
"EventType=0" & @CRLF & _
"Type=Information" & @CRLF & _
"ComputerName=COMPUTER1" & @CRLF & _
"TaskCategory=Logon" & @CRLF & _
"OpCode=Info" & @CRLF & _
"RecordNumber=1072237543" & @CRLF & _
"Keywords=Audit Success"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")