import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!Type\\=\\w+).+";
final String string = "2/01/2018 09:56:03 AM\n"
+ "LogName=Security\n"
+ "SourceName=Microsoft Windows security auditing.\n"
+ "EventCode=4624\n"
+ "EventType=0\n"
+ "Type=Information\n"
+ "ComputerName=COMPUTER1\n"
+ "TaskCategory=Logon\n"
+ "OpCode=Info\n"
+ "RecordNumber=1072237543\n"
+ "Keywords=Audit Success";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}