import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)_([a-zA-Z0-9]+)\\b";
final String string = "Calculate the _area of the _perfectRectangle object.\n\n"
+ "The _id and _age variables are both integers.\n\n"
+ "__invalidVariable _evenMoreInvalidVariable_ _validVariable\n\n"
+ "_validVariable_test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}