import re
regex = re.compile(r"(?<!\S)_([a-zA-Z0-9]+)\b", flags=re.MULTILINE)
test_str = ("Calculate the _area of the _perfectRectangle object.\n\n"
"The _id and _age variables are both integers.\n\n"
"__invalidVariable _evenMoreInvalidVariable_ _validVariable\n\n"
"_validVariable_test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")