using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:.+?\.){2,}.*$)[a-z]{1,2}(?:\.[a-z]{1,2})+$";
string input = @"a.b.c.d
a.b
a.b.c
a.bb.c
aaa.bb.c
ab.c.dd.ee";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}